libc6:amd64当前状态'halfinstall' POPos

2022-01-25 05:39:55 标签 linux

我在我的电脑上运行POP-os。昨天我运行sudo apt升级,但得到以下错误

The following packages have unmet dependencies.
 locales : Depends: libc-bin (> 2.32)
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution)

所以我运行sudo apt -fix-broken install并得到

 package libc6:amd64 is not ready for configuration
 cannot configure (current status 'half-installed')
Errors were encountered while processing:
 libc6:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

因此,尝试sudo apt安装libc6:amd64,并得到libc-bin错误之前,所以尝试sudo apt安装libc-bin,并得到以下

You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies.
 locales : Depends: libc-bin (> 2.32)
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

我觉得自己在兜圈子

# # #

$ sudo dpkg -i /var/cache/apt/archives/libc6_2.33*
$ sudo dpkg -i /var/cache/apt/archives/libc-bin_2.33-0ubuntu5_amd64.deb 
$ sudo dpkg -i /var/cache/apt/archives/libc-dev-bin_2.33-0ubuntu5_amd64.deb 
$ sudo apt --fix-broken install

也许就像对我一样。

阅读全文

▼ 版权说明

相关文章也很精彩
推荐内容
更多标签
相关热门
全站排行
随便看看

错说 cuoshuo.com —— 程序员的报错记录

部分内容根据CC版权协议转载;网站内容仅供参考,生产环境使用务必查阅官方文档

辽ICP备19011660号-5

×

扫码关注公众号:职场神器
发送: 1
获取永久解锁本站全部文章的验证码