postgreSQL +不支持postgreSQL版本

2022-01-25 05:14:04 标签 linuxpostgresqlambari

我们有postgresql版本的Ambari Hadoop集群

postgres -V
postgres (PostgreSQL) 9.2.13

从文档(https://www。postgresql。org/docs/9。2/release-9-2-13。html)我们可以看到上面的版本是不支持的

因为Ambari使用的是PostgreSQL 9。2。13版本

我想了解“不支持的PostgreSQL版本”的含义

我们需要重新安装的PostgreSQL版本是什么?

基于Ambari的版本是2。6。2。1,而在其他一些集群上我们有Ambari的版本2。6。1

和大多数项目一样,PostgreSQL核心团队承诺在一段时间内提供安全性和bug修复。Verson 9。2在2012年发布,现在已经有很长一段时间没有得到支持了。

https://www。postgresql。org/support/versioning/

如果你与红帽公司签订了支持合同,他们将为你的合同规定的任何版本提供支持。

现在,如果你必须运行一个特定版本的安巴里(我不知道安巴里是什么,我担心),而且它只支持某些版本的PostgreSQL,你应该去最新的版本,你可以。

不过,您应该始终运行最新的小版本。9。2。24是可用的,所以你根本不应该去看9。2。13。

如果你必须运行一个不支持的版本,请确保(1)你完全了解你的系统,(2)你有定期的测试备份可用,(3)你也测试了备份+恢复到一个新的支持版本的PostgreSQL。

阅读全文

▼ 版权说明

相关文章也很精彩
推荐内容
更多标签
相关热门
全站排行
随便看看

错说 cuoshuo.com —— 程序员的报错记录

部分内容根据CC版权协议转载;网站内容仅供参考,生产环境使用务必查阅官方文档

辽ICP备19011660号-5

×

扫码关注公众号:职场神器
发送: 1
获取永久解锁本站全部文章的验证码